题目来源: CodeForces
基准时间限制:1 秒 空间限制:131072 KB 分值: 10 难度:2级算法题
收藏
关注
现在有n个货物,第i个货物的重量是 2wi 。每次搬的时候要求货物重量的总和是一个2的幂。问最少要搬几次能把所有的货物搬完。
样例解释:
1,1,2作为一组。
3,3作为一组。
Input
单组测试数据。
第一行有一个整数n (1≤n≤10^6),表示有几个货物。
第二行有n个整数 w1,w2,...,wn,(0≤wi≤10^6)。
Output
输出最少的运货次数。
Input示例
样例输入1
5
1 1 2 3 3
Output示例
样例输出1
2
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1000200 //
int a[1000200];
int main()
{
int n,x,ans=0;
scanf("%d",&n);
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
scanf("%d",&x);
a[x]++;
}
for(int i=0;i<N;i++)//当a[n]之后还会继续进行下去所以N要大一些
{
if(a[i]){
ans+=a[i]%2;
a[i+1]+=a[i]/2;
}
}
printf("%d\n",ans);
return 0;
}