Anniversary party Time Limit: 1000MS Memory Limit: 65536KTotal Submissions: 8926 Accepted: 5135
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: L K It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 0 0Output
Output should contain the maximal sum of guests' ratings.Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0Sample Output
5Source
Ural State University Internal Contest October'2000 Students Session[Submit] [Go Back] [Status] [Discuss]
link:http://poj.org/problem?id=2342
题意:有n个人要开一个PARTY,编号1到n,每个人都有一个欢乐值,并且每个人都有一个直接上司,为了让气氛更好,要求在这n个人中选一些人去参加PARTY,并且选出的这些人中任意两个人之间都没有直接上司或直接下属关系,求选出人的最大欢乐值;
这n个人通过直接上司或直接下属关系构成了一棵树:
如果把父节点看做直接上司,那么子节点为下属,把父节点看做下属,那么子节点为上司;
定义:dp[i][0] 为第i个人不选择所获得的最大欢乐值;
dp[i][1] 为第i个人被选择所获得的最大欢乐值;
假设选 i 则不能选 j, 那么有转移方程 :
dp[ i ][0] += max( dp[ j ][0] , dp[ j ][1]);
dp[ i ][1] += dp[ j ][0];
//注意是+=:因为一个父节点有多个子节点;
//选 i 不选 j 意思是选了上司则不能选下属,选了下属不能选他上司;
用DFS遍历这棵树,每个顶点被访问,且只被访问一次。
AC code:
#include<cstdio> #include<algorithm> #include<vector> #include<cstring> #define me(i,j) memset(i,j,sizeof(i)); using namespace std; const int maxn=6005; vector<int>son[maxn]; bool vis[maxn]; int dp[maxn][2]; void dfs(int root) { vis[root]=1; for(int i=0;i<son[root].size();i++) { int v=son[root][i]; if(!vis[v]) { dfs(v); dp[root][1]+=dp[v][0]; dp[root][0]+=max(dp[v][0],dp[v][1]); } } } int main(){ int n; while(~scanf("%d",&n)){ //memset(vis,0,sizeof(vis)); me(vis,0); me(dp,0); for(int i=1;i<=n;i++){ son[i].clear(); scanf("%d",&dp[i][1]); dp[i][0]=0; } int l,k; while(~scanf("%d%d",&l,&k),(l+k)){ son[k].push_back(l); son[l].push_back(k); } dfs(1); printf("%d\n",max(dp[1][0],dp[1][1])); } }