[Android]Call requires API level 24(current minimum is 21):android.icu.util.calendar问题解决

xiaoxiao2021-02-28  12

Androidstudio 出现 Call requires API level 24(current minimum is 21):android.icu.util.calendar 问题时的办法

1、设置minSDK,在AndroidManifest中添加minSdkVersion设置最小版本列 2、导入 Java.util.Calendar;代替Android.icu.util.calendar import java.util.Calendar; 因为android.icu.util.calendar 是代替java.util.Calendar,但是android.icu.util.calendar只允许使用在API24以上

厦门德仔 认证博客专家 项目实施 软件开发 数据分析 毕业于南昌大学,英语6级,拥有超过13年的工作经验,数据库工程师(中级),ERP认证工程师,FRCA报表工程师,美国PMP项目管理师,具有项目管理能力,拥有多年项目实施与运维,精通SQL数据库,Asp.net和数据分析管理和开发。曾在台企,港企,美企,民企实施过多个完整ERP,WMS,EHR,OA,BI等项目。
转载请注明原文地址: https://www.6miu.com/read-450148.html

最新回复(0)