Romantic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 6016 Accepted Submission(s): 2563
Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input
77 51
10 44
34 79
Sample Output
2 -3
sorry
7 -3
Author
yifenfei
Source
HDU女生专场公开赛——谁说女子不如男
思路:裸扩展欧几里得,注意x不为负数,long long用I64输入输出。
# include <iostream>
# include <cstdio>
# define LL long long
using namespace std;
LL x, y, d;
LL ex_gcd(LL a, LL b)
{
if(b == 0)
{
x = 1;
y = 0;
return a;
}
d = ex_gcd(b, a%b);
LL t = x;
x = y;
y = t-(a/b)*y;
return d;
}
int main()
{
LL a, b;
while(~scanf("%lld%lld",&a,&b))
{
d = ex_gcd(a, b);
if(d != 1)
{
puts("sorry");
continue;
}
LL k = x/b;
if(x-b*k < 0)
--k;
printf("%I64d %I64d\n",x-b*k, y+a*k);
}
return 0;
}