Bone Collector II
Time Limit : 5000/2000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 19 Accepted Submission(s) : 16
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:
Here is the link:
http://acm.hdu.edu.cn/showproblem.php?pid=2602
Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.
If the total number of different values is less than K,just ouput 0.
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2
31).
Sample Input
3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1
Sample Output
12
2
0
Author
teddy
Source
百万秦关终属楚
题意:
01背包 第K优解。
point:
没有。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
int dp[1002][33];
int val[102];
int w[102];
bool cmd(int a,int b)
{
return a>b;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof dp);
int n,v,k;
scanf("%d %d %d",&n,&v,&k);
for(int i=1; i<=n; i++) scanf("%d",&val[i]);
for(int i=1; i<=n; i++) scanf("%d",&w[i]);
for(int i=1; i<=n; i++)
{
int a[33],b[33];
for(int j=v; j>=w[i]; j--)
{
for(int p=1; p<=k; p++)
{
a[p]=dp[j][p];
b[p]=dp[j-w[i]][p]+val[i];
}
a[k+1]=-1;//这两个很重要
b[k+1]=-1;//这两个很重要
int fa=1,fb=1,fz=1;
while(fz<=k&&(a[fa]!=-1||b[fb]!=-1))
{
if(a[fa]<b[fb])
{
dp[j][fz]=b[fb];
fb++;
}
else
{
dp[j][fz]=a[fa];
fa++;
}
if(dp[j][fz]!=dp[j][fz-1])
{
fz++;
}
}
}
}
printf("%d\n",dp[v][k]);
}
}