夹角有多大II
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 8000 Accepted Submission(s): 4044
Problem Description
这次xhd面临的问题是这样的:在一个平面内有两个点,求两个点分别和原点的连线的夹角的大小。
注:夹角的范围[0,180],两个点不会在圆心出现。
Input
输入数据的第一行是一个数据T,表示有T组数据。
每组数据有四个实数x1,y1,x2,y2分别表示两个点的坐标,这些实数的范围是[-10000,10000]。
Output
对于每组输入数据,输出夹角的大小精确到小数点后两位。
Sample Input
2
1 1 2 2
1 1 1 0
Sample Output
0.00
45.00
Author
xhd
纯数学知识,另外注意一点,C++里面的反三角函数得到的是弧度而不是角度,所以答案转换一下就行了
#include<cstdio>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<set>
#include<cstring>
#include<string>
#include<iostream>
#include<cmath>
using namespace std;
int main (){
int t;
scanf("%d",&t);
while(t--){
double x1,y1,x2,y2;
scanf("%lf %lf %lf %lf",&x1,&y1,&x2,&y2);
printf("%.2f\n",acos((x1*x2+y1*y2)/(sqrt(x1*x1+y1*y1)*sqrt(x2*x2+y2*y2)))*180/3.141592);
//弧度*180/PI=角度,向量积来求cos值;
}
}