解决yum安装报错Protected multilib versions

xiaoxiao2021-03-01  5

在安装Linux环境下的Nginx时,执行命令 yum install gcc gcc-c++ make automake autoconf libtool pcre pcre-devel zlib zlib-devel openssl openssl-devel

因为组件zlib版本冲突的原因,安装nginx不成功

但是安装zlib时候报错。

yum install -y zlib zlib-devel  

(-y 指的是如果需要选yes no的自动y)下面是报错

Protected multilib versions: zlib-1.2.7-17.el7.x86_64 != zlib-1.2.7-15.el7.i686  

原因是因为多个库不能共存,不过更新的话也并不行,但是可以在安装命令后面加上

--setopt=protected_multilib=false  

完整命令就是

yum install -y zlib zlib-devel --setopt=protected_multilib=false  

我个人的完整命令是

  yum install gcc gcc-c++ make automake autoconf libtool pcre pcre-devel zlib zlib-devel openssl openssl-devel --setopt=protected_multilib=false --skip-broken

好了,完美解决,Prefect

转载请注明原文地址: https://www.6miu.com/read-3650285.html

最新回复(0)