0043-【宏基因组】-16S分析使用conda安装qiime1平台

xiaoxiao2021-03-01  20

1. 安装miniconda

下载页面https://conda.io/miniconda.html

bash Miniconda3-latest-Linux-x86_64.sh

2. 安装qiime1

由于qiime1官网已经停止维护,且有些依赖包只能使用旧版本,因此,建议使用虚拟环境的方法进行安装。不然会与系统的软件冲突。如系统默认版本为python3,matplotlib版本为最高级。

命令解析: - 创建虚拟环境qiime1 - 指定安装的软件python=2.7 qiime matplotlib=1.4.3 mock nose - 指定channel的通道bioconda

conda create -n qiime1 python=2.7 qiime matplotlib=1.4.3 mock nose -c bioconda

安装完成后,底部显示:

# # To activate this environment, use: # > source activate qiime1 # # To deactivate an active environment, use: # > source deactivate #

查看虚拟环境

$conda info -e # conda environments: # base * /home/toucan/miniconda3 qiime1 /home/toucan/miniconda3/envs/qiime1

激活虚拟环境

环境激活后,前头显示虚拟环境的名称

$source activate qiime1 (qiime1) toucan@tssys /home/toucan/software Thu Jun 14 16:58 forstart # 确认是否安装成功 print_qiime_config.py -t

命令查看

/home/toucan/miniconda3/envs/qiime1/bin/

关闭环境

关闭环境后,会自动退出虚拟环境的前缀

(qiime1) toucan@tssys /home/toucan/software Thu Jun 14 17:05 forstart $source deactivate qiime1 toucan@tssys /home/toucan/software Thu Jun 14 17:06 forstart

安装非常顺利,大概5min。相比虚拟机,本地安装,conda实在太快了。

使用报错

执行join_paired_ends.py报错Cannot find fastq-join

通过 conda 安装 qiime 1后,在执行join_paired_ends.py时报错: burrito.util.ApplicationNotFoundError: Cannot find fastq-join. Is it installed? Is it in your path? 这是因为系统里没有fastq-join 在虚拟环境下,在终端执行以下命令安装ea-utils sudo apt install ea-utils

conda直接系统环境安装

# 直接安装 conda install qiime # 测试是否安装成功,正常输出显示为1.9.1版本 print_qiime_config.py -t # 更新qiime conda update qiime

ubuntu的apt安装

sudo apt install qiime
转载请注明原文地址: https://www.6miu.com/read-3100324.html

最新回复(0)