libreswan libevent错误

xiaoxiao2021-02-28  20

问题分析:1. 检查libreswan的版本和代码包的正确性,去官网下载比对,确认下载是最新的代码。2. 查看日志,根据event_free关键词,判断出问题的应该是libevent库,所以确认libevent,发现已经按照说明成功下载了libevent2了。3. 继续查找日志细节:—> Package libevent2.x86_64 0:2.0.21-2.el6 will be installed–> Processing Conflict: libevent2-devel-2.0.21-2.el6.x86_64 conflicts libevent-devel–> Finished Dependency ResolutionError: libevent2-devel conflicts with libevent-devel-1.4.13-4.el6.x8664从上面的提示看到是libevent2跟系统默认自带的libevent冲突了

解决:yum remove libevent-devel-1.4.13-4.el6.x86_64

yum install libevent2-devel

转载请注明原文地址: https://www.6miu.com/read-2800167.html

最新回复(0)