spacemacs安装配置

xiaoxiao2021-02-28  21

1. 安装 Emacs

spacemacs 需要 Emacs 的版本在 24 以上

2. clone spacemacs 项目到 C:\Users\用户名\.emacs.d

git clone https://github.com/syl20bnr/spacemacs

3. 启动 Emacs

spacemacs 会自动下载所需要的 package

注意:在安装过程中,出现了很多 package xxx is unavailable. Is the package name misspelled? 最后在启动 Emacs 时加上参数 –insecure 解决了该问题

4. 配置行号

在 C:\Users\用户名\.spacemacs 文件中配置

dotspacemacs-line-numbers t

5. 配置中文字体

同样是在 C:\Users\用户名\.spacemacs 文件中配置,找到

defun dotspacemacs/user-config ()

加入以下代码即可

(dolist (charset '(kana han cjk-misc bopomofo)) (set-fontset-font (frame-parameter nil 'font) charset (font-spec :family "仿宋" :size 20)))
转载请注明原文地址: https://www.6miu.com/read-2799991.html

最新回复(0)