Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 28879 Accepted Submission(s): 12146
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Source
HDU 2007-Spring Programming Contest
Recommend
lcy
题意:找到第一个匹配的下标。
裸的KMP,直接代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int t[1000005],p[10005],ne[10005];
void makeNext(const int p[],int ne[],int len)
{
ne[0]=0;
for(int i=1,k=0;i<len;i++)
{
while(k>0&&p[i]!=p[k]) k=ne[k-1];
if(p[i]==p[k]) k++;
ne[i]=k;
}
}
int kmp(const int t[],const int p[],int ne[],int n,int m)
{
int ans=0;
makeNext(p,ne,m);
for(int i=0,k=0;i<n;i++)
{
while(k>0&&t[i]!=p[k]) k=ne[k-1];
if(t[i]==p[k]) k++;
if(k==m)
{
ans=i-m+2;
return ans;
}
}
return -1;
}
int main()
{
int c;
scanf("%d",&c);
for(int i=1;i<=c;i++)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&t[i]);
for(int i=0;i<m;i++)
scanf("%d",&p[i]);
printf("%d\n",kmp(t,p,ne,n,m));
}
return 0;
}