Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21391 Accepted Submission(s): 12815
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
Author
CHEN, Gaoli
Source
ZOJ Monthly, January 2003
Recommend
Ignatius.L
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MS(a,b) memset(a,b,sizeof(a))
const int N=150000;
int n,c[N];
int lowbit(int x)
{
return x&(-x);
}
void update(int p,int val)
{
while(p<=n)
{
c[p]+=val;
p+=lowbit(p);
}
}
int sum(int p)
{
int s=0;
while(p>0)
{
s+=c[p];
p-=lowbit(p);
}
return s;
}
int main()
{
/*freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);*/
int b[6000],i,ans,s1=0,j;
while(~scanf("%d",&n))
{
MS(c,0);
for(i=1;i<=n;i++)
{
scanf("%d",&b[i]);
b[i]++;
s1+=(i-1)-sum(b[i]);
//sum(x):表示该位置之前小于x的数有几个。
update(b[i],1);
}
ans=s1;
for(i=1;i<n;i++)
{
s1+=n-b[i]-(b[i]-1);
//把第一个数移到最后位置:逆序数先减少b【i】-1个,再增加n-b【i】个。
ans=min(ans,s1);
}
printf("%d\n",ans);
}
return 0;
}