解决国内gem不能用的问题

xiaoxiao2021-02-28  13

最近在安装SASS的时候,用到gem命令,但是运行出行如下错误!

C:\Users\len>gem install sass ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError) Errno::ETIMEDOUT: A connection attempt failed because the connected party di d not properly respond after a period of time, or established connection failed because connected host has failed to respond. - connect(2) for "rubygems.global. ssl.fastly.net" port 443 (https://api.rubygems.org/quick/Marshal.4.8/sass-3.4.13 .gemspec.rz)

原因是ruby 的gem被和谐了,现在淘宝的ruby工程师架设了rubygems的国内镜像。使用方法如下:

$ gem sources --remove https://rubygems.org/ $ gem sources -a https://ruby.taobao.org/ $ gem sources -l *** CURRENT SOURCES *** https://ruby.taobao.org

然后在运行gem命令就可以了!

C:\Users\len>gem install sass Fetching: sass-3.4.13.gem (100%) Successfully installed sass-3.4.13 Parsing documentation for sass-3.4.13 Installing ri documentation for sass-3.4.13 Done installing documentation for sass after 5 seconds 1 gem installed
转载请注明原文地址: https://www.6miu.com/read-2350069.html

最新回复(0)