A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
附代码
#include <iostream>
#include <cstring>
using namespace std;
int n,a[25],book[25];
bool isPrime(int x)
{
if(x <= 1)
return 0;
for(int i = 2;i*i<=x;i++)
if(x % i == 0)
return 0;
return 1;
}
void dfs(int x)
{
if(x == n + 1)
{
for(int i = 1;i<=n;i++)
{
if(isPrime(a[1] + a[n]))
{
if(i == n)
cout<<a[n]<<endl;
else
cout<<a[i]<<" ";
}
}
return;
}
else
{
for(int i = 2;i<=n;i++)
{
if(book[i] == 0)
{
if(isPrime(a[x-1] + i))
{
a[x] = i;
book[i] = 1;
dfs(x+1);
book[i] = 0;
}
else
continue;
}
}
}
}
int main()
{
int cnt = 1;
while(cin >> n)
{
memset(a,0,sizeof(a));
memset(book,0,sizeof(book));
a[1] = 1;
cout<<"Case "<<cnt++<<":"<<endl;
dfs(2);
cout<<endl;
}
}