gcc 降级的解决方法

xiaoxiao2021-02-28  9

在进行caffe和MATLAB配置时,有时会出现以下错误:

“MEX matlab/+caffe/private/caffe_.cpp 

使用 ‘g++’ 编译。 

警告: 您使用的 gcc 版本为 ‘4.8.4’。不支持该版本的 gcc。MEX 当前支持的版本为 ‘4.7.x’。”

在网上找了教程但没有一次性成功的,下面是对本人有用的解决方法:

先安装gcc 4.7,在终端执行的安装命令: sudo apt-get install gcc-4.7 g++-4.7 g++-4.7-multilib gcc-4.7-multilib

在终端执行以下系统gcc降级命令:

sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.7 100 

sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.8 50  sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 100  sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 50  sudo update-alternatives --install /usr/bin/cpp cpp /usr/bin/cpp-4.7 100  sudo update-alternatives --install /usr/bin/cpp cpp /usr/bin/cpp-4.8 50

验证gcc-4.7是否安装并成为系统的默认版本:

gcc -v  再次编译  sudo make matcaffe

这是我在进行配置过程中的经验之谈,希望对大家有所帮助。

转载请注明原文地址: https://www.6miu.com/read-1650165.html

最新回复(0)