appium1.4版本,每次运行appium时需要安装unlock,setting,inputmanager三个apk文件的解决方法

xiaoxiao2021-02-28  9

appium 1.4版本才会有如下问题,最新的appium16也会有如下问题,但整体版本使用比较方便,建议大家使用appium16版本

在使用appium执行自动化脚本时,首次运行脚本时会在手机中安装unlock,setting,inputmanager三个apk,以达到让appium控制app的目的,但是运行完一次之后,在OPPO,vivo,以及其他一些手机上出现了这样的情况,每次运行都需要安装这三个apk,导致脚本执行过程非常不流畅,经过多次尝试,可以使用如下方式解决:

前提是手机中已经运行过一次脚本,并且已经成功安装过unlock,setting,inputmanager,如果没有安装,下面的步骤可能会影响到脚本在手机上的正确执行

1.首先在网上找了个方法,注释掉C:\Program Files (x86)\Appium\node_modules\appium\lib\devices\android\android.js文件中的两行

执行这个步骤后,unlock,setting这两个apk将不会重复安装,但是还是会提示安装inputmanager

目前没找到方法,以后会更新

 有兴趣的同学可以加群讨论 :489650589

转载请注明原文地址: https://www.6miu.com/read-1150329.html

最新回复(0)